ProMods 2.17 – Bugfix Release

While we are still working hard on ProMods 2.20 which will once again introduce a wide variety of new landscapes, cities and other infrastructure, some undocumented modifications in the base game resulted in some incompatibilities of our mod and the most current ETS2 version. ProMods 2.17 only fixes reported bugs since the release of the previous version, and no new content.

The flag pole issue in Scandinavia, caused by the Heavy Cargo DLC update, unfortunately was not fixable with a hotfix. And we are still receiving complaints about frequently reported bugs such as the hole on the E4 in Stockholm – which have been fixed in our hotfix release about 8 weeks ago.

It seems to be the best way forward not to issue hotfixes but instead keep on releasing full release packs even for bugfix versions. This means longer downloads on your end, but a lot less support for us. So we can concentrate on fixing bugs existing in the most current mod version and working on upcoming versions.

This is a full map release. So after updating the files in your mod folder, ensure to delete our previous hotfix files.

Download ProMods 2.17

Stummer

I'm into truck simulators for several years now and made some simple mods for "18 Wheels of Steel - Haulin". Besides being a moderator in the forum, I maintain the blog and the social media channels.

18 Responses to ProMods 2.17 – Bugfix Release

  1. Nigel says:

    would you be able to add bristol into the map at some stage and maybe devon.

  2. I beg for Hot Fixes, please give us Hot Fixes.

  3. Lordi05 says:

    Did i need version 2.17? becouse ive load and paid for version 2.16 2 weeks bevore

    • Stummer Stummer says:

      If you can live with the bugs in 2.16 (or even didn’t notice one), then you don’t need to update. As the text says: 2.17 is simply a bugfix version without new content.

  4. erkki123 says:

    Why my game crashed with promods 2.17, without promods not crashed

  5. DiegoLican says:

    Hello. in my case the version 2.17 gives me crash after crash rather than in version 2.16 not I happen…

  6. Majara says:

    im trying to unzip the file but it requires password

  7. Bonzo says:

    Hi, I’m new to ets2 and unsure if I need to download the 2.17. I have installed viva la france, scandinavian and going east.
    If I do / have to then would it conflict with any of the other installs?

  8. Sandy Cooray says:

    Hi, I downloaded promods 2.17 bt the first file is not downloading well. tried many times n its says “the archive is corrupt” pls,could you support me how to download well

    thanks a lot

  9. sheldoncooper300 says:

    de: hallo, ich habe schon letztes mal die version 2.16 gedownloadet und bei part1 hatte ich das problem beim entpacken so wie jetzt bei der version 2.17, da kommt immer wieder die meldung das die korrupt sei, habe es neu gedownloadet und antivirus aus gemacht hat alles nichts gebracht was muss ich machen damit es funktioniert?

    e:
    Hello, I have downloaded the last version of version 2.16 and at part1 I had the problem when unpacking as now with the version 2.17, there comes again and again the message that the corrupt, it has reloaded and antivirus made everything has nothing What should I do to make it work?

  10. bozz says:

    hmmm. when will v 2.20 get out?

    • Stummer Stummer says:

      We’re still testing the 2.20 version and fixing bugs. The estimated release date is as always: “When it’s ready”

Leave a Reply

Your email address will not be published. Required fields are marked *

fifteen + thirteen =